The LookSee Platform is not currently compatible with older browsers such as Internet Explorer. We recommend using a modern browser such as Chrome, Firefox, Safari or Edge.